Uploaded image for project: 'Fabric'
  1. Fabric
  2. FAB-16129

BYFN when up with RAFT does not function correctly

    Details

    • Steps to Reproduce:
      Hide
      (Please add steps to reproduce)
      At the suggestion of coding team, cleared all docker containers, pruned system and volume and reloaded fabric-samples from scratch:
      docker kill $(docker ps -q)
      docker rm $(docker ps -a -q)
      echo y | docker system prune -a
      echo y | docker volume prune

      mkdir -p $GOPATH/src/github.com/hyperledger
      cd $GOPATH/src/github.com/hyperledger
      rm -rf fabric-samples
      curl -sSL http://bit.ly/2ysbOFE | bash -s -- 1.4.2 1.4.2 0.4.15
      cd fabric-samples

      Startemad BYFN steps:

      ./byfn.sh generate
      ./byfn.sh up -o etcdraft

      Despite getting a good all successful messages back to the terminal window -- no errors and what appears to be a successful END message -- the only containers that load are as follows (in order of appearance in Kitematic): orderer.example; orderer4.example; orderer5.example; peer0.org1; peer0.org2; peer1.org1; peer1.org2 -- both orderer2.example and orderer3.example are stopped.

      First two lines of each container read the follow despite *explicitly* starting the network with RAFT not kafka:

      2019-07-29 19:51:00.757 UTC [localconfig] completeInitialization -> INFO 001 Kafka.Version unset, setting to 0.10.2.0
      2019-07-29 19:51:00.810 UTC [orderer.common.server] prettyPrintStruct -> INFO 002 Orderer config values:
      Show
      (Please add steps to reproduce) At the suggestion of coding team, cleared all docker containers, pruned system and volume and reloaded fabric-samples from scratch: docker kill $(docker ps -q) docker rm $(docker ps -a -q) echo y | docker system prune -a echo y | docker volume prune mkdir -p $GOPATH/src/github.com/hyperledger cd $GOPATH/src/github.com/hyperledger rm -rf fabric-samples curl -sSL http://bit.ly/2ysbOFE | bash -s -- 1.4.2 1.4.2 0.4.15 cd fabric-samples Startemad BYFN steps: ./byfn.sh generate ./byfn.sh up -o etcdraft Despite getting a good all successful messages back to the terminal window -- no errors and what appears to be a successful END message -- the only containers that load are as follows (in order of appearance in Kitematic): orderer.example; orderer4.example; orderer5.example; peer0.org1; peer0.org2; peer1.org1; peer1.org2 -- both orderer2.example and orderer3.example are stopped. First two lines of each container read the follow despite *explicitly* starting the network with RAFT not kafka: 2019-07-29 19:51:00.757 UTC [localconfig] completeInitialization -> INFO 001 Kafka.Version unset, setting to 0.10.2.0 2019-07-29 19:51:00.810 UTC [orderer.common.server] prettyPrintStruct -> INFO 002 Orderer config values:

      Description

      When following https://hyperledger-fabric.readthedocs.io/en/release-1.4/build_network.html

      in an attempt to bring up first-network with raft ordering service, several containers have issues.

       

      Contact me for container logs.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              CT123 CT123 123
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:

                Git Source Code