Uploaded image for project: 'Fabric'
  1. Fabric
  2. FAB-18404

Can't build sample applicaiton due to dependency conflics

    XMLWordPrintable

Details

    • Bug
    • Status: Unverified
    • Lowest
    • Resolution: Unresolved
    • None
    • None
    • fabric-samples
    • cd into the application-java folder and run mvn install

    Description

      In fabric-samples/commercial-paper/organization/digibank/application-java the build fails with the following message:

      [*ERROR*] Failed to execute goal on project commercial-paper: Could not resolve dependencies for project commercial-paper:commercial-paper:jar:0.0.1-SNAPSHOT: Failed to collect dependencies for commercial-paper:commercial-paper:jar:0.0.1-SNAPSHOT: Could not resolve version conflict among [org.hyperledger.fabric:fabric-gateway-java:jar:[2.0,3.0) -> org.hyperledger.fabric-sdk-java:fabric-sdk-java:jar:[2.2.0,2.3.0) -> io.grpc:grpc-netty:jar:1.31.0 -> io.grpc:grpc-core:jar:[1.31.0,1.31.0], org.hyperledger.fabric-chaincode-java:fabric-chaincode-shim:jar:[2.0,3.0) -> io.grpc:grpc-netty-shaded:jar:1.31.1 -> io.grpc:grpc-core:jar:[1.31.1,1.31.1]] ->

      Attachments

        Activity

          People

            Unassigned Unassigned
            tschonnycache Jonas Kreusch
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: