Uploaded image for project: 'Fabric'
  1. Fabric
  2. FAB-18501

Fabric 1.4.X >> Fabric 2.2.x Upgrade

    XMLWordPrintable

Details

    • Task
    • Status: Backlog
    • High
    • Resolution: Unresolved
    • None
    • None
    • fabric-docs, fabric-samples
    • None

    Description

      Hyperledger fabirc 1.4 LTS was active from last 2 years, there are many networks that need to be migrated to fabric 2.2 LTS. There is good documentation at fabric read the docs but it's very time-consuming and even not work properly. Theoretically, it's a good document but following those instructions are a nightmare. There should be some scripts to do easily upgrade as we had in fabric 1.4 like https://github.com/hyperledger/fabric-samples/blob/release-1.4/first-network/scripts/upgrade_to_v14.sh

      It will be a great help if there are ready scripts to do fabric upgrades, help to community and companies to upgrade to the latest LTS. This way more and more networks will be using the latest LTS. It's good to have an upgrade script when there are more LTS versions so the community can take advantage of the latest LTS software version.

      Attachments

        Activity

          People

            Unassigned Unassigned
            knagware9 Kamlesh Nagware
            Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated: