Uploaded image for project: 'Fabric'
  1. Fabric
  2. FAB-6909

Upgrade node SDK support to requiring node LTS (8.9.0+)

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • High
    • Resolution: Done
    • None
    • v1.1.0-alpha
    • fabric-sdk-node
    • None

    Description

      now that node.js engine LTS has been updated from 6.9 to 8.9, we should move the SDK support to ^8.9.0 accordingly, and remove support for 6.9.

      Although, it would be a good idea to keep the implementation to be node 6 compliant, until such a time when:

      • a node 8-only feature is required, or
      • using a node 8-only feature significantly improves the quality of the implementation

      As a result, CI jobs running on node 6 should continue for now, along with node 8 CI jobs.

      Attachments

        Issue Links

          Activity

            People

              jimthematrix Jim Zhang
              jimthematrix Jim Zhang
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: