Uploaded image for project: 'Fabric SDK Node'
  1. Fabric SDK Node
  2. FABN-141

CI build script needs to install node v6.9.x

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Medium
    • Resolution: Done
    • None
    • None

    Description

      The build script is installing node v7.4.0, but we currently support v6.9.x, so this needs to be changed to v6.9.x.

      In the fabric-sdk-node README.md,
      To build and test, the following pre-requisites must be installed first:
      node runtime version 6.9.x, note that 7.0 is not supported at this point
      npm tool version 3.10.x

      https://github.com/hyperledger/ci-management/blob/master/packer/provision/docker.sh#L156

      deb_install_node()

      { # Node install pushd /usr/local curl https://nodejs.org/dist/v7.4.0/node-v7.4.0-linux-x64.tar.xz | tar xJf - --strip-components=1 popd echo npm -v: `npm -v` echo node -v: `node -v` }

      Attachments

        Activity

          People

            Unassigned Unassigned
            cdaughtr Caroline Daughtrey
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: