Uploaded image for project: 'Indy Node'
  1. Indy Node
  2. INDY-1219

validator-info and read_ledger give inconsistent responses in node on provisional

    Details

    • Type: Bug
    • Status: Complete
    • Priority: Highest
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.4
    • Component/s: validator-info
    • Labels:
    • Environment:

      Steward node on the Provisional network, running 1.2.50

      Description

      T-Shirt: S

      In trying to repair the provisional network, we have a node where the validator-info tool gives a different response for the state of the pool and the domain ledgers than the read_ledger tool does. Because of this, we are unable to determine if the ledger is in sync with the network, and we have no confidence in the state of the validator.

      We urgently need to get the network into an operational state, so we need effort to get this node operational. We have restarted the service, and the results have not changed. We have deleted the validator-info.log file and verified that a fresh one was written after the restart.

      Attached are files containing the outputs of validator-info, read_ledger for the domain and pool ledgers, and the indy log.  

        Attachments

        1. log.tar
          0.9 kB
        2. read_ledger_config.out
          29 kB
        3. read_ledger_domain.out
          10 kB
        4. read_ledger_pool.out
          10 kB
        5. validator_info.out
          0.8 kB

          Issue Links

            Activity

              People

              • Assignee:
                ozheregelya Olga Zheregelya
                Reporter:
                mgbailey Mike Bailey
                Watchers:
                Alexander Shcherbakov, Mike Bailey, Olga Zheregelya, Renata Toktar
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: