Uploaded image for project: 'Indy Node'
  1. Indy Node
  2. INDY-1415

Incorrect read_ledger info with seq_no parameter

    Details

    • Type: Bug
    • Status: New
    • Priority: Medium
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: 1.12.2
    • Component/s: None
    • Labels:

      Description

      Build Info:
      indy-node 1.4.464

      Steps to Reproduce:
      1. Install or upgrade pool to 1.4.464 version.
      2. Run `read_ledger --type=domain --seq_no 1` or with any existing seq_no.
      3. Check output.

      Actual Results:
      "hKxyZXFTaWduYXR1cmWAo3R4boOkZGF0YYOkZGVzdLZWNFNHUlU4Nlo1OGQ2VFY3UEJVZTZmpHJvbGWhMKZ2ZXJrZXm3fkNvUkVSNjNEVlluV1p0Szh1QXpOYniobWV0YWRhdGGApHR5cGWhMat0eG5NZXRhZGF0YYGlc2VxTm8Bo3ZlcqEx"

      Expected Results:
      There should be the same output as with any other key:
      1 {"reqSignature":{},"txn":{"data":

      {"dest":"V4SGRU86Z58d6TV7PBUe6f","role":"0","verkey":"~CoRER63DVYnWZtK8uAzNbx"}

      ,"metadata":{},"type":"1"},"txnMetadata":

      {"seqNo":1}

      ,"ver":"1"}

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              VladimirWork Vladimir Shishkin
              Watchers:
              Vladimir Shishkin
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: