Uploaded image for project: 'Indy Node'
  1. Indy Node
  2. INDY-1464

AttributeError: 'NoneType' object has no attribute 'request' during load

    Details

    • Type: Bug
    • Status: Complete
    • Priority: Medium
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.5
    • Component/s: None
    • Labels:
      None
    • Environment:

      indy-node 1.4.496

    • Epic Link:
    • Sprint:
      EV 18.14 Monitoring/Stability

      Description

      Steps to Reproduce:
      1. Prepare new pool with 25 nodes
      2. Run load test from 5 instances

      python3 perf_processes.py -g pool_transactions_genesis -b 10 -r 2 -m t -c 100 -t 50 -n 3 -k "{\"nym\": 4, \"attrib\": 1, \"schema\": 1, \"cred_def\": 1}"
      

      500 clients, 30 writes / sec

      Actual results:
      Pool stopped writing after only 11k txns (and less than 90 minutes) and cannot finish catchup

      Additional info:
      Logs will be available on LogProcessor:~/logs/attribute_error_11jul2018

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                zhigunenko.dsr NIkita Zhigunenko
                Reporter:
                zhigunenko.dsr NIkita Zhigunenko
                Watchers:
                Alexander Shcherbakov, Andrew Nikitin, NIkita Zhigunenko
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: