Uploaded image for project: 'Indy Node'
  1. Indy Node
  2. INDY-1748

Failed to upgrade from Sovrin 1.1.24 to Sovrin 1.1.26

    Details

    • Type: Bug
    • Status: Complete
    • Priority: Highest
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.6.78
    • Component/s: None
    • Labels:
      None
    • Documentation Impact:
      Unset
    • Sprint:
      Ev 18.20, Ev 18.21

      Description

      Build Info:
      sovrin 1.1.24
      indy-node 1.6.73
      plugins 0.9.3~

      Steps to Reproduce:
      1. Install sovrin 1.1.24 (0.9.3~ plugins dependency) pool.
      2. Try to upgrade it to sovrin 1.1.26 (0.9.4~ plugins dependency) using POOL_UPGRADE command.
      3. Check package versions and journalctl.

      Actual Result:
      Upgrade is failed.

      Oct 10 10:23:02 290bca03d347 env[62]: + echo 'Try to donwload indy version indy-anoncreds=1.0.11 python3-indy-crypto=0.4.3 indy-plenum=1.6.52 indy-node=1.6.74 sovrin=1.1.26'
      Oct 10 10:23:02 290bca03d347 env[62]: Try to donwload indy version indy-anoncreds=1.0.11 python3-indy-crypto=0.4.3 indy-plenum=1.6.52 indy-node=1.6.74 sovrin=1.1.26
      Oct 10 10:23:02 290bca03d347 env[62]: + apt-get -y update
      Oct 10 10:23:02 290bca03d347 env[62]: Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
      Oct 10 10:23:03 290bca03d347 env[62]: Hit:2 http://archive.ubuntu.com/ubuntu xenial InRelease
      Oct 10 10:23:03 290bca03d347 env[62]: Hit:3 http://archive.ubuntu.com/ubuntu xenial-updates InRelease
      Oct 10 10:23:03 290bca03d347 env[62]: Hit:4 http://archive.ubuntu.com/ubuntu xenial-backports InRelease
      Oct 10 10:23:04 290bca03d347 env[62]: Hit:5 https://repo.sovrin.org/deb xenial InRelease
      Oct 10 10:23:04 290bca03d347 env[62]: Fetched 107 kB in 1s (75.7 kB/s)
      Oct 10 10:23:05 290bca03d347 env[62]: Reading package lists...
      Oct 10 10:23:06 290bca03d347 env[62]: + apt-get --download-only -y --allow-downgrades --allow-change-held-packages install indy-anoncreds=1.0.11 python3-indy-crypto=0.4.3 indy-plenum=1.6.52 indy-node=1.6.74 sovrin=1.1.26
      Oct 10 10:23:07 290bca03d347 env[62]: Reading package lists...
      Oct 10 10:23:07 290bca03d347 env[62]: Building dependency tree...
      Oct 10 10:23:07 290bca03d347 env[62]: Reading state information...
      Oct 10 10:23:07 290bca03d347 env[62]: indy-anoncreds is already the newest version (1.0.11).
      Oct 10 10:23:07 290bca03d347 env[62]: python3-indy-crypto is already the newest version (0.4.3).
      Oct 10 10:23:07 290bca03d347 env[62]: Some packages could not be installed. This may mean that you have
      Oct 10 10:23:07 290bca03d347 env[62]: requested an impossible situation or if you are using the unstable
      Oct 10 10:23:07 290bca03d347 env[62]: distribution that some required packages have not yet been created
      Oct 10 10:23:07 290bca03d347 env[62]: or been moved out of Incoming.
      Oct 10 10:23:07 290bca03d347 env[62]: The following information may help to resolve the situation:
      Oct 10 10:23:07 290bca03d347 env[62]: The following packages have unmet dependencies:
      Oct 10 10:23:07 290bca03d347 env[62]:  sovrin : Depends: sovtoken (= 0.9.4+1.59) but 0.9.3+12.58 is to be installed
      Oct 10 10:23:07 290bca03d347 env[62]:           Depends: sovtokenfees (= 0.9.4+1.59) but 0.9.3+13.58 is to be installed
      Oct 10 10:23:07 290bca03d347 env[62]:  sovtoken : Depends: indy-plenum (= 1.6.51) but 1.6.52 is to be installed
      Oct 10 10:23:07 290bca03d347 env[62]: E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
      Oct 10 10:23:07 290bca03d347 env[62]: + ret=100
      Oct 10 10:23:07 290bca03d347 env[62]: + '[' 100 -ne 0 ']'
      Oct 10 10:23:07 290bca03d347 env[62]: + echo 'Failed to obtain indy-anoncreds=1.0.11 python3-indy-crypto=0.4.3 indy-plenum=1.6.52 indy-node=1.6.74 sovrin=1.1.26'
      Oct 10 10:23:07 290bca03d347 env[62]: Failed to obtain indy-anoncreds=1.0.11 python3-indy-crypto=0.4.3 indy-plenum=1.6.52 indy-node=1.6.74 sovrin=1.1.26
      Oct 10 10:23:07 290bca03d347 env[62]: + exit 1
      Oct 10 10:23:07 290bca03d347 env[62]: Upgrade from 1.1.24 to 1.1.26 failed: upgrade script failed, exit code is 1
      Oct 10 10:23:07 290bca03d347 env[62]: Trying to rollback to the previous version upgrade script failed, exit code is 1
      

        Attachments

        1. 1748.tar.gz
          644 kB
        2. journal
          94 kB

          Activity

            People

            • Assignee:
              VladimirWork Vladimir Shishkin
              Reporter:
              VladimirWork Vladimir Shishkin
              Watchers:
              Alexander Shcherbakov, Andrew Nikitin, Dmitry Surnin, Vladimir Shishkin
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: