Uploaded image for project: 'Indy Node'
  1. Indy Node
  2. INDY-1850

Sovrin package can't be upgraded

    Details

    • Type: Bug
    • Status: Complete
    • Priority: High
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.6.79
    • Component/s: None
    • Labels:
    • Documentation Impact:
      Unset
    • Sprint:
      EV 18.24

      Description

      Environment:
      indy-node 1.6.675 -> sovrin 1.1.89 -> sovrin 1.1.90
      docker pool

      Steps to Reproduce:
      1. Setup the pool of 10 nodes with indy-node 1.6.675 and sovrin 1.1.62 (last not pinned version).
      2. Send pool upgrade transaction to sovrin 1.1.89 (depending on indy-node 1.6.675).
      3. Send pool upgrade transaction to sovrin 1.1.90 (depending on indy-node 1.6.678).

      Actual Results:
      Upgrade failed due to following error:

      Nov 14 16:49:16 8fcd6b2e84ed env[5196]: The following packages have unmet dependencies:
      Nov 14 16:49:17 8fcd6b2e84ed env[5196]: sovrin : Depends: indy-node (= 1.6.678) but 1.6.675 is to be installed
      Nov 14 16:49:17 8fcd6b2e84ed env[5196]: E: Unable to correct problems, you have held broken packages.
      Nov 14 16:49:17 8fcd6b2e84ed env[5196]: + ret=100
      Nov 14 16:49:17 8fcd6b2e84ed env[5196]: + '[' 100 -ne 0 ']'
      Nov 14 16:49:17 8fcd6b2e84ed env[5196]: + echo 'Failed to obtain sovrin=1.1.90'
      Nov 14 16:49:17 8fcd6b2e84ed env[5196]: Failed to obtain sovrin=1.1.90
      Nov 14 16:49:17 8fcd6b2e84ed env[5196]: + exit 1
      

      Expected Results:
      Sovrin should be upgraded.

        Attachments

          Activity

            People

            • Assignee:
              ozheregelya Olga Zheregelya
              Reporter:
              ozheregelya Olga Zheregelya
              Watchers:
              Dmitry Surnin, Olga Zheregelya, Vladimir Shishkin
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: